Moodbar for amaroK SVN

Current version: exscalibar-1.0.4.

Here you can find the latest ebuild for exscalibar. It will install support for the moodbar plugin used by amaroK.

To use it:

  • Add the ‘moodbar’ use-flag to your /etc/make.conf
  • Download the package
  • Check your /etc/make.conf and see what the value of your PORTDIR_OVERLAY variable is
  • Change to one of your ‘overlay’ directories and execute:
    tar zxvf /path/to/exscalibar.tar.gz
  • download and install the latest amarok-svn ebuild (check here for information about the latest amaroK ebuild).

Filed as Gentoo bug nr: 121718

Update: exscalibar is now in portage. There is no need to download this ebuild anymore. The one in portage has a couple of additional features as well, so I encourage everyone to use that one.

5 Replies to “Moodbar for amaroK SVN”

  1. This morning I got an email from Gusufyr stating the following:

    Hi,
    I have done an ebuild for exscalibar which lets you have the support for moodbar in amarok. For more explanations about this feature see here http://cratoo.de/content/view/143/64/ . It’s just a bar that let you see the mood of a song but it’s very funny.
    I saw you have posted amarok-svn ebuilds on your blog, so I join a patch for having the moodbar support in amarok-svn, it adds a depend with a use flag, and my ebuild for exscalibar.

    No better way to start the new year than with some new extended functionality. So I’ve tested and improved the ebuild a little bit and updated the amarok ebuild, for you all to enjoy.

    Thanks go out to Gusufyr for creating the first build.

    Jord

  2. I tried this ebuild, but I got some sandbox violations:

    ————————— ACCESS VIOLATION SUMMARY —————————
    LOG FILE = “/var/log/sandbox/sandbox-media-libs_-_exscalibar-1.0.4-11803.log”

    open_wr: /usr/qt/3/etc/settings/.qtrc.lock
    open_wr: /usr/qt/3/etc/settings/.qtrc.lock
    open_wr: /usr/qt/3/etc/settings/.qt_plugins_3.3rc.lock
    open_wr: /usr/qt/3/etc/settings/.qtrc.lock
    ——————————————————————————–

    Now I know I could just disable the sandbox feature, but I don’t think that’s the best solution, so if anybody knows a different way to fix that?

  3. Did you download today, or did you have an old version? I think I saw it with an old version…

  4. I have no clue… Don’t have the error on my machine… Maybe someone else can help. The only thing I would know is:

    FEATURES="-sandbox -usersandbox" emerge exscalibar

    But you are already aware of that.

Leave a Reply